实验要求:掌握RIP协议的简单认证及MD5认证
拓扑如下
简单认证
R1
enable 进入特权模式
config 进入全局模式
hostname R1 修改名称
interface s0/1 进入端口
ip address 192.168.1.1 255.255.255.0 设置IP地址
physical-layer speed 64000 设置同步时钟
exit 返回上一级
router rip 启动RIP协议
version 2 选择版本
network 192.168.1.0 添加直连网段到RIP
interface s0/1 进入端口
ip rip authentication simple 启动RIP简单认证
ip rip password 978285 设置认证密码
R2
enable 进入特权模式
config 进入全局模式
hostname R2 修改名称
interface s0/2 进入端口
ip address 192.168.1.2 255.255.255.0 设置IP地址
physical-layer speed 64000 设置同步时钟
interface l0 进入端口
ip address 192.168.2.254 255.255.255.0 设置IP地址
exit 返回上一级
router rip 启动RIP协议
network 192.168.1.0 将直连网段添加到RIP
network 192.168.2.0 将直连网段添加到RIP
interface s0/2 进入端口
ip rip authentication simple 启动RIP简单认证
ip rip password 978285 设置认证密码
MD5认证
R1
enable 进入特权模式
config 进入全局模式
hostname R1 修改名称
interface s0/1 进入端口
ip address 192.168.1.1 255.255.255.0 设置IP地址
physical-layer speed 64000 设置同步时钟
exit 返回上一级
router rip 启动RIP协议
version 2 选择版本
network 192.168.1.0 添加直连网段到RIP
interface s0/1 进入端口
ip rip authentication md5 启动RIPMD5认证
ip rip md5-key 1 md5 978285 设置认证密码
R2
enable 进入特权模式
config 进入全局模式
hostname R2 修改名称
interface s0/2 进入端口
ip address 192.168.1.2 255.255.255.0 设置IP地址
physical-layer speed 64000 设置同步时钟
interface l0 进入端口
ip address 192.168.2.254 255.255.255.0 设置IP地址
exit 返回上一级
router rip 启动RIP协议
network 192.168.1.0 将直连网段添加到RIP
network 192.168.2.0 将直连网段添加到RIP
interface s0/2 进入端口
ip rip authentication md5 启动md5认证
ip rip md5-key 1 md5 978285 设置认证密码
相关命令
ip rip authentication simeple 启动简单认证
ip rip password [passwor] 设置密码
ip rip authentication md5 启动MD5认证
ip rip md5-key [key-ID] md5 [password] 设置密码