算法笔记练习 5.2 最大公约数与最小公倍数 问题 A: Least Common Multiple
题目
题目描述
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
输入
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
输出
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
样例输入
2
2 3 5
3 4 6 12
样例输出
15
12
思路
要求 m 个数的 LCM,先求前两个数的 LCM,再用结果去算和第三个数的 LCM,直到把所有数都算完,结果即为所求。
步骤:
- 令 ;
- 令 ;
- ,重复 2 直到 ;
- 输出 .
细节:特判一下只有一个数的情况。
代码
#include <stdio.h>
// 返回 a,b 的最大公约数
long gcd(long a, long b){
return !b ? a : gcd(b, a % b);
}
int main() {
long m, n, i, ans, input;
while (scanf("%ld", &m) != EOF) {
while (m--) {
scanf("%ld", &n);
scanf("%ld", &ans);
if (n == 1){
printf("%ld\n", ans);
continue;
}
for (i = 0; i < n-1; ++i) {
scanf("%ld", &input);
ans = ans / gcd(ans, input) * input; //ans = LCM(ans,input)
}
printf("%ld\n", ans);
}
}
return 0;
}