poj3734(Blocks)快速幂+组合数学

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6


题意:n个方块排成一列,每块可以涂成红蓝绿黄四种颜色,问红色方块和绿色方块个数同时为偶数的方案有多少种?


题解:设ai, bi, ci分别表示到第i块为止红绿都是偶数、红绿有一个是偶数、红绿都是奇数方案数,那么

ai+1 = 2ai + bi

bi+1 = 2ai + 2bi + 2ci

ci+1 = bi + 2ci

写成矩阵形式后用快速幂即可求解


#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;

typedef vector<int> vec;
typedef vector<vec> mat;
const int Mod = 10007;

mat mul(mat& a, mat& b)
{
    mat c(3, vec(3));
    for (int i = 0; i < 3; ++i)
        for (int k = 0; k < 3; ++k)
            for (int j = 0; j < 3; ++j)
                c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % Mod;
    return c;

}

mat pow(mat& a, int n)
{
    mat b(3, vec(3));
    for (int i = 0; i < 3; ++i)
        b[i][i] = 1;
    while (n > 0)
    {
        if (n&1)
            b = mul(b, a);
        a = mul(a, a);
        n >>= 1;
    }
    return b;
}

int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        int n;
        scanf("%d", &n);
        mat a(3, vec(3));
        a[0][0] = 2; a[0][1] = 1; a[0][2] = 0;
        a[1][0] = 2; a[1][1] = 2; a[1][2] = 2;
        a[2][0] = 0; a[2][1] = 1; a[2][2] = 2;
        a = pow(a, n);
        printf("%d\n", a[0][0]);
    }
    return 0;
}


posted on 2020-01-17 01:03  godweiyang  阅读(109)  评论(0编辑  收藏  举报

导航