poj3292(Semi-prime H-numbers)筛法
Description
This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.
An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.
As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.
For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.
Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.
Input
Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.
Output
For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.
Sample Input
21 85 789 0
Sample Output
21 0 85 5 789 62
题意很好理解,用素数打表方法就行了。
#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <numeric>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;
const int maxn = 1000010;
int HPrime[maxn];
void init()
{
memset(HPrime, 0, sizeof(HPrime));
for (int i = 5; i < maxn; i += 4)
for (int j = i; j < maxn*1.0/i; j += 4)
if (!HPrime[i] && !HPrime[j])
HPrime[i*j] = 1;
else
HPrime[i*j] = -1;
int cnt = 0;
for (int i = 0; i < maxn; ++i)
if (HPrime[i] == 1)
HPrime[i] = ++cnt;
else
HPrime[i] = cnt;
}
int main()
{
init();
int h;
while (scanf("%d", &h) == 1 && h)
printf("%d %d\n", h, HPrime[h]);
return 0;
}
posted on 2020-01-17 01:03 godweiyang 阅读(53) 评论(0) 编辑 收藏 举报