1005 Spell It Right

1005 Spell It Right
 

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five


这是签到题目把?
import java.util.*;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        String str = sc.next();
        sc.close();
        int res = 0;
        for(int i=0;i<str.length();i++)
            res+=Integer.valueOf(str.charAt(i)-48);
        String result = String.valueOf(res);
        for(int i=0;i<result.length();i++) {
            switch(result.charAt(i)) {
            case '0':
                System.out.print("zero");
                break;
            case '1':
                System.out.print("one");
                break;
            case '2':
                System.out.print("two");
                break;
            case '3':
                System.out.print("three");
                break;
            case '4':
                System.out.print("four");
                break;
            case '5':
                System.out.print("five");
                break;
            case '6':
                System.out.print("six");
                break;
            case '7':
                System.out.print("seven");
                break;
            case '8':
                System.out.print("eight");
                break;
            case '9':
                System.out.print("nine");
                break;
            }
            if(i!=result.length()-1) System.out.print(" ");
        }
    }
}

 

 

posted @ 2019-05-21 23:23  秃桔子  阅读(264)  评论(0编辑  收藏  举报

如果您有编程方面或者学术方面的需求请在微信公众号搜索

桔子科研


或者识别下方二维码,第一时间获取编程有趣的知识和最新科研学术成果。