Description
There is a string S.S only contain lower case English character.(10length(S)1,000,000)
How many substrings there are that contain at least k(1k26) distinct characters?
 
Input
There are multiple test cases. The first line of input contains an integer T(1T10) indicating the number of test cases. For each test case:
The first line contains string S.
The second line contains a integer k(1k26).
 
Output
For each test case, output the number of substrings that contain at least k dictinct characters.
 
Sample Input
2
abcabcabca
4
abcabcabcabc
3
 
Sample Output
0
55
 
 
对于给定长度的字符串要求出它的子串数目,对子串的要求是每个自子串中至少含有k个不同的字符。
这道题的数据量同样很大,我开始连暴力的想法都没有T_T。
听完学长讲题解,双指针(网上大家也都叫尺取法),好巧妙啊,觉得应该好难敲就好久都没实现,等好长时间以后写了一次,不知怎么一直RE,请教学长后,学到了这饿个很精炼的代码。
 
 
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e6+5;
char a[maxn];
int vis[100],T,n,len;

int f(){
	int sum = 0;
	for(int i=0;i<26;i++){
		if(vis[i])
			sum++;
	}
	return sum>=n;//已经找到了满足条件的一种子串了。 
}

int main(){
	scanf("%d",&T);
	while(T--){
		scanf("%s",a);
		scanf("%d",&n);
		memset(vis,0,sizeof(vis));
		int l =0 ,r = 0;len=strlen(a);ll ans = 0;
		while(r<len){
			vis[a[r]-'a']++;
			while(f()){
				vis[a[l++]-'a']--;
			} 
			ans+=l;// [l-1,r] 为最短答案,那么[0...l-1,e] 都是答案。所以,ans += l; 
			r++;
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 

 

 posted on 2017-08-12 17:03  Lslsa  阅读(167)  评论(2编辑  收藏  举报