PAT_A 1084 Broken Keyboard & PAT_B 1029 旧键盘
PAT_A 1084 Broken Keyboard & PAT_B 1029 旧键盘
分析
逐个字符相比较即可,要注意两字符串的长度
PAT_A 1084 Broken Keyboard
题目的描述
On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.
Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.
Input Specification:
Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _
(representing the space). It is guaranteed that both strings are non-empty.
Output Specification:
For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.
Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI
PAT_B 1029 旧键盘
题目的描述
旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。
输入格式:
输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _
(代表空格)组成。题目保证 2 个字符串均非空。
输出格式:
按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有 1 个坏键。
输入样例:
7_This_is_a_test
_hs_s_a_es
输出样例:
7TI
AC的代码
#include<bits/stdc++.h>
using namespace std;
int main(){
string a,b,r;
cin>>a>>b;
int i=0,j=0;
set<char> h;
while(i<a.size()&&j<b.size()){
while(a[i]!=b[j]){
a[i]=toupper(a[i]);
if(h.count(a[i]) == 0){
h.insert(a[i]);
cout<<a[i];
// r+=(a[i]);
}
i++;
}
i++;j++;
}
//判断b结束后的字符
while(i<a.size()){
a[i]=toupper(a[i]);
if(h.count(a[i]) == 0){
h.insert(a[i]);
cout<<a[i];
// r+=(a[i]);
}
i++;
}
cout<<endl;
return 0;
}
本文来自博客园,作者:ghosteq,转载请注明原文链接:https://www.cnblogs.com/ghosteq/p/16405633.html