PAT_A 1083 List Grades

PAT_A 1083 List Grades

分析

题目要求将学生按成绩非递增排序,且题目中保证各个学生成绩不同,所以就是按照成绩降序排序。

最后需要输出成绩在指定区间内的学生的姓名与学号。

题目没有给出学生个数N的范围,所以就猜了一个数,侥幸AC了。

题目的描述

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

AC的代码

#include<bits/stdc++.h>

using namespace std;

class Person{
    public:
    char name[12],ID[12];
    int grade;
    Person(){};
};
bool cmp(Person a,Person b){
    return a.grade > b.grade ? true : false;
}
int main(){
    int N,g1,g2;
    bool empty=false;
    scanf("%d",&N);
    array<Person,10001> people;
    for(int i=0;i<N;i++){
        scanf("%s%s%d",people[i].name,people[i].ID,&people[i].grade);
    }
    scanf("%d%d",&g1,&g2);
    sort(people.begin(),people.begin()+N,cmp);
    for(int i=0;i<N;i++){
        if(people[i].grade>=g1&&people[i].grade<=g2){
            printf("%s %s\n",people[i].name,people[i].ID);
            empty = true;
        }
    }
    if(!empty){
        printf("NONE\n");
    }
    return 0;
}
posted @ 2022-01-25 19:44  ghosteq  阅读(23)  评论(0编辑  收藏  举报