PAT_A 1075 PAT Judge

PAT_A 1075 PAT Judge

分析

题目要求对输入的数据的分数按照规则排序,规则与一般的程序竞赛类似。其中,若任意一次提交都会将使对应学生对应题目的分数大于等于0(不论是否编译通过>-1),但并不一定改变该学生的有效提交次数(-1时有效提交不变)。同时,可能会出现分数为0的情况,要特别注意。

排序的规则如下:

  • 按照总分非递增序排序
  • 总分相同时,按照满分题目个数的非递增序
  • 满分题目个数仍相同时,按照ID递增排序
  • 排名会存在并列的情况,输出要体现
  • 有效提交次数为0的不在最终输出中显示

题目的描述

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, \(N\ (≤10^4)\), the total number of users, \(K\ (≤5)\), the total number of problems, and \(M\ (≤10^5)\), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

AC的代码

#include<bits/stdc++.h>

using namespace std;

class Students{
    public:
    array<int,5> problems;
    int vilsub,persub,tot,id;
    Students(){
        for(int i=0;i<problems.size();i++){
            problems[i]=-5;
        }
        vilsub=0,persub=0,tot=0;
    }
};
bool cmp(Students a,Students b){
    if(a.tot==b.tot){
        return a.persub==b.persub
            ? a.id<b.id
            : a.persub > b.persub;
    }
    else return a.tot > b.tot;
}
int main(){
    int N,K,M;
    array<Students,10001> stu;
    array<int, 5> fullmarks={0};
    scanf("%d%d%d",&N,&K,&M);
    for(int i=0;i<K;i++){
        scanf("%d",&fullmarks[i]);
    }
    while(M--){
        int id,pn,grades;
        scanf("%d%d%d",&id,&pn,&grades);
//         if(grades<0)continue;
        if(grades>=0)stu[id-1].vilsub+=1;
        if(stu[id-1].problems[pn-1]<grades){
            stu[id-1].problems[pn-1]= 
                grades>=0 ? grades : 0;
            if(grades==fullmarks[pn-1]){
                stu[id-1].persub+=1;
            }
        }
    }
    for(int i=0;i<N;i++){
        for(auto j:stu[i].problems){
            if(j>0){
                stu[i].tot+=j;
            }
        }
        stu[i].id = i+1;
    }
    sort(stu.begin(),stu.begin()+N,cmp);
    int ranks=1;
    for(int i=0;i<N;i++){
        if(stu[i].vilsub<1)continue;
        if(i>0&&stu[i].tot!=stu[i-1].tot){
            ranks=i+1;
        }
        printf("%d %05d %d",ranks,stu[i].id,stu[i].tot);
         if(stu[i].problems[0]>=0){
            printf(" %d",stu[i].problems[0]);
        }
        else printf(" -");
        for(int j=1;j<K;j++){
            if(stu[i].problems[j]>=0){
                printf(" %d",stu[i].problems[j]);
            }
            else printf(" -");
        }
        printf("\n");
    }
    return 0;
}
posted @ 2022-01-24 23:02  ghosteq  阅读(25)  评论(0编辑  收藏  举报