PAT_A 1028 List Sorting
PAT_A 1028 List Sorting
分析
题目要求对输入的数据按照C值的不同,分别对不同关键字按规则排序。偷懒的话可以写三个cmp调用sort来实现。
C的具体规则为:
C==1
时,按照ID递增排序C==2
时,按照名字的非递减序排序,若重名则按照ID的递增排序C==3
时,按照分数的非递减序排序,若同分则按照ID的递增排序
题目的描述
Excel can sort records according to any column. Now you are supposed to imitate this function.
Input Specification:
Each input file contains one test case. For each case, the first line contains two integers \(N\ (≤10^5)\) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).
Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 1:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2:
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3:
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9
Sample Output 3:
000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90
鸣谢用户 wangzhj 补充数据!
AC的代码
#include<bits/stdc++.h>
using namespace std;
class Student{
public:
char ID[10];
char names[10];
int grade;
Student(){}
Student(char id[],char n[],int g){
strcpy(ID,id);
strcpy(names,n);
grade = g;
}
};
bool cmp0(Student a,Student b){
return strcmp(a.ID,b.ID)<0;
}
bool cmp1(Student a,Student b){
return strcmp(a.names,b.names)==0
? strcmp(a.ID,b.ID)<0
: strcmp(a.names,b.names)<0;
}
bool cmp2(Student a,Student b){
return a.grade == b.grade
? strcmp(a.ID,b.ID)<0
: a.grade<b.grade;
}
int main(){
int N,C,n;
array<Student,100001> students;
scanf("%d%d",&N,&C);
n=N;
while(N--){
char id[15],names[15];
int g;
scanf("%s%s%d",id,names,&g);
students[N] = Student(id,names,g);
}
switch(C){
case 1:
sort(students.begin(),students.begin()+n,cmp0);
break;
case 2:
sort(students.begin(),students.begin()+n,cmp1);
break;
case 3:
sort(students.begin(),students.begin()+n,cmp2);
break;
}
for(int i=0;i<n;i++){
printf("%s %s %d\n",
students[i].ID,students[i].names,students[i].grade);
}
return 0;
}
本文来自博客园,作者:ghosteq,转载请注明原文链接:https://www.cnblogs.com/ghosteq/p/15841307.html