PAT_A 1005 Spell It Right

PAT_A 1005 Spell It Right

分析

将输入的数字,每一位相加求和后,按照题目要求进行输出即可。

题目的描述

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an \(N (≤10^{100})\).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

AC的代码

#include<bits/stdc++.h>

using namespace std;

int main(){
    string num;
    cin>>num;
    long long sum=0;
    array<string, 10> words ={
        "zero","one","two","three","four","five","six","seven","eight","nine"
    };
    for(auto i: num){
        sum += i - '0';
    }
    num = to_string(sum);
    cout<<words[num[0]-'0'];
    for(int i=1;i<num.size();i++){
        cout<<' '+words[num[i]-'0'];
    }
    cout<<endl;
    return 0;
}
posted @ 2022-01-24 22:54  ghosteq  阅读(17)  评论(0编辑  收藏  举报