PAT_A 1019 General Palindromic Number
PAT_A 1019 General Palindromic Number
分析
本题输入为十进制数N,基数b,要求验证N在b进制下是否为回文数,并进行相应的输出。所以只需将N转换为b进制数后验证即可。
题目的描述
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits \(a_i\) as \(\sum_{i=0}^{k}(a_ib^i)\). Here, as usual,\(0≤a_i<b\) for all \(i\) and \(a_k\) is non-zero. Then N is palindromic if and only if \(a_i=a_{k−i}\) for all\(i\). Zero is written 0 in any base and is also palindromic by definition.
Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where\(0<N≤10^9\) is the decimal number and \(2≤b≤10^9\) is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line Yes
if N is a palindromic number in base b, or No
if not. Then in the next line, print N as the number in base b in the form "\(a_k\ a_{k−1}\ ...\ a_0\)". Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1
鸣谢网友“CCPC拿不到牌不改名”修正数据!
AC的代码
#include<bits/stdc++.h>
using namespace std;
int main(){
long long N,b;
int f=0;
cin>>N>>b;
if(N==0){
cout<<"Yes\n0"<<endl;
return 0;
}
vector<long long > num;
while(N){
num.push_back(N%b);
N/=b;
}
for(int i=0;i<num.size();i++){
if(num[i]!=num[num.size()-1-i]){
cout<<"No\n";
f=1;
break;
}
}
if(!f){
cout<<"Yes\n";
}
cout<<num[num.size()-1];
for(int i=num.size()-2;i>=0;i--){
cout<<' '<<num[i];
}
cout<<endl;
return 0;
}
本文来自博客园,作者:ghosteq,转载请注明原文链接:https://www.cnblogs.com/ghosteq/p/15841257.html