PAT_A 1042 Shuffling Machine

PAT_A 1042 Shuffling Machine

分析

本题是模拟洗牌机?即给定初始序列,给定洗牌的次数N以及卡牌的序号,顺序遍历卡牌的序号,将原序列中的卡牌放置序号列中序号对应的位置得到新的序列,重复N次完成洗牌...具体可以看原题或代码

题目的描述

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S

AC的代码

#include<bits/stdc++.h>

using namespace std;

int main(){
    int K,f=0;
    vector<int> ord (54,0);
    vector<vector<string> > orders(2,vector<string>(54));
    orders[0]={"S1", "S2", "S3", "S4", "S5", "S6", "S7", "S8", "S9", "S10", "S11", "S12", "S13",
               "H1", "H2", "H3", "H4", "H5", "H6", "H7", "H8", "H9", "H10", "H11", "H12", "H13",
               "C1", "C2", "C3", "C4", "C5", "C6", "C7", "C8", "C9", "C10", "C11", "C12", "C13",
               "D1", "D2", "D3", "D4", "D5", "D6", "D7", "D8", "D9", "D10", "D11", "D12", "D13",
               "J1", "J2"};
//     char a[5]={'S','H','C','D','J'};
//     for(int i=0;i<5;i++){
//         for(int j=1;j<14;j++){
//             if(j==3&&i==4)break;
//             cout<<'\"'<<a[i]<<j<<"\", ";
//         }
//     }
    cin>>K;
    while(K){
        K--;
        if(f==0){
            for(int i=0;i<54;i++){
                cin>>ord[i];
                orders[1][ord[i]-1]=orders[0][i];
            }
        }
        else{
            for(int i=0;i<54;i++){
                //cin>>ord[i];
                orders[(f+1)%2][ord[i]-1]=orders[(f)%2][i];
            }
        }
        f++;

    }
    for(int i=0;i<ord.size();i++){
        cout<<orders[f%2][i];
        if(i!=ord.size()-1)cout<<' ';
        else cout<<endl;
    }
    return 0;
}
posted @ 2022-01-24 22:37  ghosteq  阅读(22)  评论(0编辑  收藏  举报