[POJ] 1458 Common Subsequence

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 56614 Accepted: 23609
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
Source
Southeastern Europe 2003

LCS问题
f[i][j]表示S长度为i的前缀和T长度为j的前缀的LCS
f[i][j]=f[i-1][j-1]+1 (s[i]==t[j])
f[i][j]=max( f[i-1][j] , f[i][j-1] ) (else)

//Writer:GhostCai && His Yellow Duck
#include<iostream>
#include<cstring>
#define MAXN 500
using namespace std;
char s[MAXN],t[MAXN];
int lens,lent;
int f[MAXN][MAXN];
int main(){
while(cin>>s+1>>t+1){
memset(f,0,sizeof(f));
lens=strlen(s+1);
lent=strlen(t+1);
for(int i=1;i<=lens;i++){
for(int j=1;j<=lent;j++){
if(s[i]==t[j]){
f[i][j]=f[i-1][j-1]+1;
}else{
f[i][j]=max(f[i-1][j],f[i][j-1]);
}
}
}
cout<<f[lens][lent]<<endl;
}
return 0;
}
posted @   GhostCai  阅读(82)  评论(0编辑  收藏  举报
编辑推荐:
· DeepSeek 解答了困扰我五年的技术问题
· 为什么说在企业级应用开发中,后端往往是效率杀手?
· 用 C# 插值字符串处理器写一个 sscanf
· Java 中堆内存和栈内存上的数据分布和特点
· 开发中对象命名的一点思考
阅读排行:
· DeepSeek 解答了困扰我五年的技术问题。时代确实变了!
· PPT革命!DeepSeek+Kimi=N小时工作5分钟完成?
· What?废柴, 还在本地部署DeepSeek吗?Are you kidding?
· DeepSeek企业级部署实战指南:从服务器选型到Dify私有化落地
· 程序员转型AI:行业分析
点击右上角即可分享
微信分享提示