1020 月饼 (25 分)C语言
月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。
注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。
输入格式:
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。
输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。
输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50
思路1:
利用循环找到单价最高的月饼出售,直到满足市场最大需求量
#include <stdio.h>
int main(){
int n;
float d, profit = 0, price[1000], stock[1000];
int i, max;
scanf("%d %f", &n, &d);
for(i = 0; i < n; i++) scanf("%f", stock+i);
for(i = 0; i < n; i++) scanf("%f", price+i);
while(d > 0){
max = 0;
for(i = 0; i < n; i++){
if(price[i] / stock[i] > price[max] / stock[max]){
max = i;
}
}
if(d > stock[max]){
profit += price[max];
d -= stock[max];
price[max] = 0;
}
else{
profit += d * price[max] / stock[max];
d = 0;
}
}
printf("%.2f\n", profit);
return 0;
}
思路2:
将月饼按照单价降序进行排列。我使用了C自带的快速排序和自己写的选择排序函数。
#include <stdio.h>
#define MAXN 1001
/*定义月饼结构体为mooncake*/
typedef struct {
float stock; //库存。
float price; //每款月饼总价。
float each; //每款月饼单价。
} mooncake;
int cmp ( const void *a, const void*b ) {
mooncake c1 = *(mooncake *)a; //将指针a强制转化为mooncake结构体类型。
mooncake c2 = *(mooncake *)b;
return c2.each > c1.each; //按单价each降序返回。
}
int main(void) {
int N, i;
float D, total;
mooncake cake[MAXN];
scanf("%d %f", &N, &D);
for ( i = 0; i < N; i++ ) scanf("%f", &cake[i].stock);
for ( i = 0; i < N; i++ ) scanf("%f", &cake[i].price);
for ( i = 0; i < N; i++ ) cake[i].each = cake[i].price / cake[i].stock;
/*数组名,数组大小,每个数组元素大小,比较函数*/
qsort ( cake, N, sizeof(mooncake), cmp ); //sizeof(cake[0])也行。
total = 0;
/*月饼已经按单价降序排号,只需遍历*/
for( i = 0; i < N && D > 0; i++ ) {
if ( cake[i].stock <= D ) { //某款月饼库存比需求量低。
total += cake[i].price; //这款月饼总价全部放入销售额。
D -= cake[i].stock; //需求量扣除这款月饼的库存。
} else { //某款月饼的库存满足了需求量。
total += D * cake[i].each; //销售额 = 需求量 * 这款月饼单价。
D = 0; //需求置零,退出循环。
}
}
printf("%.2f\n", total);
return 0;
}
欢迎查阅