郑州轻工业大学2021-2022(2)数据结构习题集 6-9

郑州轻工业大学2021-2022(2)数据结构习题集

6-9 学生成绩链表处理 (20 分)


题目详情

本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。


函数接口定义:

struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );

函数createlist利用scanf从输入中获取学生的信息,将其组织成单向链表,并返回链表头指针。链表节点结构定义如下:

struct stud_node {
    int              num;      /*学号*/
    char             name[20]; /*姓名*/
    int              score;    /*成绩*/
    struct stud_node *next;    /*指向下个结点的指针*/
};

输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。

函数deletelist从以head为头指针的链表中删除成绩低于min_score的学生,并返回结果链表的头指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct stud_node {
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};

struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );

int main()
{
    int min_score;
    struct stud_node *p, *head = NULL;

    head = createlist();
    scanf("%d", &min_score);
    head = deletelist(head, min_score);
    for ( p = head; p != NULL; p = p->next )
        printf("%d %s %d\n", p->num, p->name, p->score);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0
80

输出样例:

2 wang 80
4 zhao 85

我的答案:

struct stud_node* createlist()
{
    struct stud_node* head, * p, * tail;
    head = tail = NULL;
    p = (struct stud_node*)malloc(sizeof(struct stud_node));
    scanf("%d", &p->num);
   
    while (p->num!=0)
    {
    
       scanf("%s %d",p->name,&p->score);
     
       if (head == NULL)
           head = tail = p;
       else
       {
           tail->next = p;
           tail = p;
       }
       p = (struct stud_node*)malloc(sizeof(struct stud_node));
       scanf("%d", &p->num);
    }
    
    return head;
}
struct stud_node* deletelist(struct stud_node* head, int min_score)
{
    struct stud_node* p = head, * temp;
   
   
    while (p)
    {
        if (p->score < min_score)
        {
            if (p == head)           //头需要删除
            {
                temp = head;         //临时存头以便释放
                head = head->next;  //头后移来实现删除头
                p = head;           //新头继续
                free(temp);
                continue;
            }

            if (p->next)            //头不需要删除且要删除节点不是尾部
            {
                temp->next = p->next; //删除节点
                p = temp->next;
                continue;
            }
            else                //到尾部了
            {
                temp->next = NULL;
                break;
            }

        }
        else                //不需要删除,则temp和p后移一个节点
        {
            temp = p;
            p = p->next;
        }
        
    }
    return head;
}
posted @ 2022-04-18 22:18  ggaoda  阅读(1)  评论(0编辑  收藏  举报  来源