8.3 第五场 VC Is All You Need
8.3 第五场 VC Is All You Need
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2033 Accepted Submission(s): 845
Problem Description
Three points example.
Four points example.
In this picture you can draw a line to seperate these 3 points in the two dimensional plane to keep points with the same color lie in the same side no matter how to color each point using either blue or red.
But in k dimensional real Euclidean space Rk, can you find n points satisfying that there always exsit a k−1 dimensional hyperplane to seperate them in any one of 2n coloring schemes?
Input
The first line contains only one integer T(1≤T≤105) denoting the number of test cases.
Each of next T lines contains two integers n,k∈[2,1018] seperated by a space.
Output
Print Yes if you can find one solution, or print No if you cannot.
Sample Input
3
2 2
3 2
4 2
Sample Output
Yes
Yes
No
大概题意:
判断能否找到一条直线分开两种颜色的方案
思路:
找规律,归纳即可
代码:
#include<iostream>
using namespace std;
int main() {
ios::sync_with_stdio(false);
int t;
cin >> t;
while (t--) {
long long int n, k;
cin >> n >> k;
if (n - k < 2) {
cout << "Yes" << endl;
} else {
cout << "No" << endl;
}
}
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 单线程的Redis速度为什么快?
· 展开说说关于C#中ORM框架的用法!
· Pantheons:用 TypeScript 打造主流大模型对话的一站式集成库
· SQL Server 2025 AI相关能力初探
· 为什么 退出登录 或 修改密码 无法使 token 失效