More is better(MST)(求无向图中最大集合元素个数)

More is better
Time Limit:1000MS     Memory Limit:102400KB     64bit IO Format:%I64d & %I64u

Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 
 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input

4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output

4 2

Hint

 A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers. 
         
 
#include<stdio.h>
#include<algorithm>
using namespace std;
int p[10000010] , rk[10000010] , maxn ;
int m ;

void init ()
{
    for (int i = 0 ; i <= 10000010 ; i++) {
        p[i] = i ;
        rk[i] = 1 ;
    }
    maxn = 0 ;
}

int find (int x)
{
    return x == p[x] ? x : p[x] = find (p[x]) ;
}

void Union (int x , int y)
{
    p[x] = y ;
    rk[y] += rk[x] ;
    maxn = max (maxn , rk[y]) ;
    rk[x] = 0 ;
}

int main ()
{
        //freopen ("a.txt" , "r" , stdin ) ;
        int x , y ;
        while (~ scanf ("%d" , &m) ) {
            init () ;
            for (int i = 0 ; i < m ; i++ ) {
                scanf ("%d%d" , &x , &y ) ;
                x = find (x) ;
                y = find (y) ;
                if (x != y)
                    Union ( x , y ) ;
            }
            if (maxn )
                printf ("%d\n" , maxn ) ;
            else
                printf ("1\n") ;
        }
        return 0 ;
}

 

 

 
posted @ 2015-02-11 15:27  92度的苍蓝  阅读(212)  评论(0编辑  收藏  举报
http://images.cnblogs.com/cnblogs_com/Running-Time/724426/o_b74124f376fc157f352acc88.jpg