HDU2795-Billboard

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.OutputFor each announcement (in the order they are given in the input file)

output

one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

题意

有一个广告板,h行,每行宽为w。每次往上面贴一张海报,长度为1×wi。每次贴的时候是遵循靠左靠前的原则。

给定贴的顺序,求每个海报放置的位置(若无法放置则为-1)

分析

经典的线段树题目,放置海报的过程可变为单点修改,修改方式是减,更新方式为求最大值,由于是优先选左,因此向下递推时优先往左子节点走

代码

#include<bits/stdc++.h>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define Start 1,n,1
#define maxn 200005
using namespace std;
int sum[maxn<<2],a[maxn],n,w,k;
void pushup(int rt)
{
    sum[rt]=max(sum[rt<<1],sum[rt<<1|1]);
}
void build(int l,int r,int rt)//构建一颗点值全为w的树
{
    if(l==r)
    {
        sum[rt]=w;
        return;
    }
    int mid=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
} 
void update(int val,int l,int r,int rt)
{
    if(l==r)
    {
        printf("%d\n",l);
        sum[rt]-=val;
        return;
    }
    int mid=(l+r)>>1;
    if(sum[rt<<1]<val)//除非左边递推不了,不然就一直往左 
    update(val,rson);
    else
    update(val,lson);
    pushup(rt);
}
int main()
{
    while(~scanf("%d%d%d",&n,&w,&k))
    {
        n=min(n,k);
        build(Start);
        for(int i=1;i<=k;i++)
        scanf("%d",&a[i]);
        for(int i=1;i<=k;i++)
        {
            if(a[i]>sum[1])
            printf("-1\n");
            else
            update(a[i],Start);
        }
    }
    return 0;
}

 

posted @ 2019-11-06 19:52  乔治莫得感情  阅读(102)  评论(0编辑  收藏  举报