Ordering Tasks

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

 

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 andmn is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

	5 4
	1 2
	2 3
	1 3
	1 5
	0 0

Sample Output

	1 4 2 5 3

//拓扑排序,使用图(二维数组)来存储各个位置之间的大小关系,例如G[0][4],则说明arr[0]<arr[4],同理G[4][2],说明arr[4]<arr[2],这里可以看到,G实际决定了数组各数的先后关系
然后利用dfs,记录dfs每个节点访问时间,接着逆序输出,具体可以参看算法导论图论章节。
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxd=110;
bool visited[maxd];
int n, m;
int g[maxd][maxd];
int topoSort[maxd];//储存排序结果
int cnt;//拓扑数组的序号
void dfs(int s)
{
    visited[s] = true;
    for(int j = 1; j <= n; j++)
        if(j!= s && g[s][j]==1 && !visited[j])
            dfs(j);
    topoSort[cnt++] = s;
}

void dfs_travel()
{
    cnt = 0;
    memset(visited, false, sizeof(visited));
    for(int i = 1; i <= n; i++)
        if(!visited[i])
            dfs(i);
}

int main()
{
    int a, b;
    while(scanf("%d%d", &n, &m))
    {
        if(n==0 && m==0) break;
        memset(g, 0, sizeof(g));
        while(m--)
        {
            scanf("%d%d", &a, &b);
            g[a][b] = 1;//g[a][b]表示a指向b
        }
        dfs_travel();
        for(int i = cnt-1; i > 0; i--)
            printf("%d ", topoSort[i]);
        printf("%d\n", topoSort[0]);
    }
    return 0;
}
View Code

 

posted @ 2016-07-21 21:44  君子酱  阅读(456)  评论(0编辑  收藏  举报