Who's in the Middle

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less. 
 

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow. 
 

Output

* Line 1: A single integer that is the median milk output. 
 

Sample Input

5 2 4 1 3 5
 

Sample Output

3

Hint

 INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3. 

//本题就是简单的排序,自己写个冒泡法也可以,但是效率太低了,可以用STL中自带的sort函数。注意使用头文件#include<algorithm>。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

int a[10010];
int main()
{   int n;
    while(scanf("%d",&n)!=EOF)
    {
           memset(a,0,sizeof(a));
           for (int i=0;i<n;i++)
            scanf("%d",&a[i]);
            sort(a,a+n);
            printf("%d\n",a[n/2]);

    }
    return 0;
}
View Code

 

 


 
posted @ 2016-07-19 14:36  君子酱  阅读(154)  评论(0编辑  收藏  举报