2778:Ride to School-poj

2778:Ride to School

总时间限制: 
1000ms
 
内存限制: 
65536kB
描述
Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike. 

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one. 

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan. 

输入
There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format: 

Vi [TAB] Ti 

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti. 

输出
Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.
样例输入
4
20	0
25	-155
27	190
30	240
2
21	0
22	34
0
样例输出
780
771
代码:
#include<iostream>
#include<stdio.h>
#include<string.h>
#include <stdlib.h>
#include<vector>
#include<queue>
#include<math.h>
using namespace std;
int main()
{
    int n;
    int v,t;
    while((cin>>n)&&(n!=0))
    {
        double time;
        double min = 0x7fffffff;
        for(int i=1;i<=n;i++)
        {
            cin>>v>>t;
            if(t < 0)
                continue;
            time=t+(4.5/double(v))*3600;//计算每个同学的时间
            if(time<min)//取时间最短的那个
            {
                min=time;
            }
        }
        cout<<ceil(min)<<endl;//ceil向上取
    }
    
    return 0;
}

 

posted @ 2017-08-18 17:25  A-inspire  Views(263)  Comments(0Edit  收藏  举报