JDOJ 2255 A+B Problem

JDOJ 2255: A+B Problem

https://neooj.com/oldoj/problem.php?id=2255

Description

Solve A+B problem without '+', '-', '*', '/'.

Input

Two integers A and B.

Output

The result for A+B.

Sample Input

12 34

Sample Output

46

HINT

 

Only use the C.

A, B  >= 0,   A+B < MAX_INT.

 

求A+B,不能使用加、减、乘、除,代码里也不能包含加减乘除号,只能用C语言提交。

 

是的,你没看错,是A+B Problem!!就是那种所有网站的第一题!跟Hello world是一个水平的!!

为什么把它放到博客里呢?

看题啊。

而且,今天坐我旁边的大佬一直在A一道Hello world的题,好像是什么清华集训队的...

水题也有翻身的时候啊!!

提供给想把万恶的基础题第五页全A掉的同学:

#include<stdio.h>
int getSum(int a,int b)
{
    int sum,carry;
    if (b==0)
        return a;
     sum=a^b;
     carry=(a&b)<<1;
     return getSum(sum,carry);
}
int main()
{
    int a,b,c;
    scanf("%d%d",&a,&b);
    c=getSum(a,b);  
    printf("%d",c);   
    return 0;
}

其实这题涉及到了一点点的位运算的思想,还是把它归到位运算去吧.

posted @ 2019-07-27 16:35  Seaway-Fu  阅读(124)  评论(0编辑  收藏  举报