zoj 3721 Final Exam Arrangement【贪心】

题目:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3721

来源:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=26644#problem/F


Final Exam Arrangement

Time Limit: 4 Seconds      Memory Limit: 65536 KB      Special Judge

In Zhejiang University, there are N different courses labeled from 1 to N. Each course has its own time slot during the week. We can represent the time slot of a course by an left-closed right-open interval [s, t).

Now we are going to arrange the final exam time of all the courses.

The final exam period will contain multiple days. In each day, multiple final exams will be held simultaneously. If two courses' time slots are not overlapped, there may be students who are attending both of them, so we cannot arrange their final exams at the same day.

Now you're to arrange the final exam period, to make the total days as small as possible.

Input

There are multiple test cases separated by blank lines.

For each ease, the 1st line contains one integer N(1<=N<=100000).

Then N lines, the i+1th line contains s and t of the interval [s, t) for the ith course.(0<=s<t<=231-1)

There is a blank line after each test case.

Output

For each case, the 1st line contains the days P in the shortest final exam period.

Next P lines, the i+1th line contains the numbers of courses whose final exam is arranged on the ith day separated by one space.

Output a blank line after each test case.

Sample Input

4
0 1
1 2
2 3
3 4

4
0 2
1 3
2 4
3 5

4
0 4
1 5
2 4
3 6

Sample Output

4
1
2
3
4

2
1 2
3 4

1
1 2 3 4


题意:感觉很奇怪,为什么重合的可以放在同一天考试,虽然AC了,但是还是没有看懂   题目意思,比赛时按照题目要求弄了下,两个排序一下就过了。(其实一个就够   了)

思路:先按照开始的时间和结束的时间从前往后排序。

          当然是先开始的 排在前面,同时开始的,先结束的排在前面了

          排序好后的第一门课当然是在第一天考试了。

          然后依次遍历后面的每一门课,如果后面一门课和前面的有相交的区间,则它们在同一天考试,此时要注意缩小这天的可以考试的区间,后开始早结束,取相交的部分。如果没有相交的部分,那么区间还是自己的开始和结束时间,只是考试时间推后了一天。

最后是输出,我是按照考试时间排序了下,再调整了下输出格式。

F Accepted 1744 KB 1210 ms C++ (g++ 4.4.5) 1206 B 2013-07-20 12:19:25

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;

const int maxn = 100000+10;
struct Class{
	int s,t;
	int flag;
	int index;
}c[maxn];

bool cmp(Class a, Class b)
{
	if(a.s != b.s) return a.s < b.s;
	else return a.t < b.t;
}

bool cmp1(Class a, Class b)
{
	if(a.flag == b.flag) return a.index <= b.index;

	else return a.flag < b.flag;
}

int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{
		for(int i = 0; i < n; i++)
		{
			scanf("%d%d", &c[i].s, &c[i].t);
			c[i].flag = 0;
			c[i].index = i+1;
		}
		sort(c,c+n,cmp);
         c[0].flag=1;
       for(int i = 1; i < n; i++)
		{
			if(c[i].s < c[i-1].t)
			{
				c[i].flag = c[i-1].flag;
				c[i].s = max(c[i].s, c[i-1].s);
				c[i].t = min(c[i].t, c[i-1].t);
			}
			else c[i].flag = c[i-1].flag+1;
		}
		int day = c[n-1].flag;

		int d = 1;
		sort(c,c+n,cmp1);
		printf("%d\n",day);

		int f = 1;

		for(int i = 0; i < n; i++)
		{

			if(c[i].flag == d  ) {
				if(f == 1) { f = 2; printf("%d", c[i].index); }
				else {
					  printf(" %d", c[i].index);
					}
			}

			else{
				printf("\n");
				d += 1;

				printf("%d", c[i].index);
			}
		}
		printf("\n");
	}
	return 0;
}


            

posted @ 2013-07-20 18:14  free斩  Views(362)  Comments(0Edit  收藏  举报