france

https://github.com/francecil

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理

D - Red and Black
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output

45 59 6 13
 


这题已经不想在吐槽什么了,n,m 和正常的出相反 害我一些细节错 一直WA 还说到底还是自己太弱了



#include<iostream>
using namespace std;

#include<string.h>
#define max 25
char map[max][max];int mmin;
long n,m,visited[max][max];
long directions[4][2]={{0,-1},{0,1},{1,0},{-1,0}};

void DFS(int x,int y)
{
    int i,mx,my;
    for(i=0;i<4;i++)
        {
            mx=x+directions[i][0];
            my=y+directions[i][1];
            if(mx>=0&&mx<m&&my>=0&&my<n)
                    {
                        if(!visited[mx][my]&&map[mx][my]=='.')
                        {
                        	visited[mx][my]=1;
                        	mmin++;
                           DFS(mx,my);
                        }
                    }
        }
}
int main()
{

    int i,j,a,b;
    while(cin>>n>>m)
    {
    	if(n==0&&m==0)break;
        memset(visited,0,sizeof(visited));

        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='@')
                    {
                       a=i,b=j;
                        }
            }
        }
        mmin=1;
        visited[a][b]=1;
        DFS(a,b);
        cout<<mmin<<endl;
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2014-07-30 01:41  france  阅读(175)  评论(0编辑  收藏  举报