cigarettes

cigarettes

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette. 
Now,do you know how many cigarettes can Tom has?

输入
First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124

题目转自南阳理工学院:http://acm.nyist.edu.cn/JudgeOnline/problemset.php


个人代码(以下原创)

#include <stdio.h>
#include <malloc.h>

int main()
{
	int m;
	scanf("%d", &m);
	while (m--)
	{
		int n, k;
		scanf("%d%d", &n, &k);
		int count = n, t = n;
		while (t > k - 1)
		{
			count += t/k;
			t = t % k + t/k;
		}
		printf("%d\n", count);
	}
	return 0;
}



posted @ 2018-02-03 19:59  focus5679  阅读(358)  评论(0编辑  收藏  举报