Lake Counting POJ - 2386

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int m, n;
char maps[100][100];

void dfs(int x, int y)
{
	
	for (int i = -1; i <= 1; i++)
	{
		for (int j = -1; j <= 1; j++)
		{
			if (maps[x+i][y+j] == 'W' && 0 <= x+i && x+i < m && 0 <= y+j && y+j < n)
			{
				maps[x+i][y+j] = '.';
				dfs(x+i, y+j);
			}
		}
	}

}

int main()
{
	while (~scanf("%d %d", &m, &n))
	{
		int count = 0;
		getchar();
		for (int i = 0; i < m; i++)
		{
			gets(maps[i]);
		}
		for (int i = 0; i < m; i++)
		{
			for (int j = 0; j < n; j++)
			{
				if (maps[i][j] == 'W')
				{
					maps[i][j] = '.';
					dfs(i, j);
					count++;
				}
			}
		}
		printf("%d\n", count);
	}

	return 0;
}


posted @ 2018-04-03 16:19  focus5679  阅读(81)  评论(0编辑  收藏  举报