Curling 2.0 POJ - 3009

Curling 2.0 POJ - 3009

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10
-1

题解+解析:

#include <iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include <cstring>
#include <queue>
#include <cmath>
typedef long long ll;
#define INF 0x7f7f7f7f
using namespace std;

char map[25][25];
int sx, sy;
int gx, gy;
int move[4][2]= {1,0,0,1,-1,0,0,-1};
int ans;
int w, h;
void dfs(int x, int y, int step)
{
	if (step > ans || step >10)//剪枝+限制条件
	{
		return;
	}
	if (x == gx && y == gy)//到达终点,记录步数
	{
		ans = step;
		return ;
	}
	for (int i = 0; i < 4; i++)//确定滑的方向
	{
		int nx = x+move[i][0], ny = y+move[i][1];
		if (0<=nx&&nx<h&&0<=ny&&ny<w&&map[nx][ny]!='1')//判断该方向是否可以滑动
		{
			while (1)
			{
				if (0<=nx&&nx<h&&0<=ny&&ny<w)//确定滑到的位置合法
				{
					if (map[nx][ny] == '1')//撞上木板
					{
						map[nx][ny] = '0';//木板碎掉
						dfs(nx-move[i][0], ny-move[i][1], step+1);//继续深搜撞上木板后的情况
						map[nx][ny] = '1';//回溯,恢复木板
						break;
					}
					if (map[nx][ny] == '3')//到达终点
					{
						dfs(nx,ny,step+1);
						break;
					}
					nx = nx + move[i][0];//继续向该方向滑动
					ny = ny + move[i][1];
				}
				else
				{
					break;
				}
			}
		}
	}

}
int main()
{
	
	while (scanf("%d%d",&w, &h)&&(w||h))
	{
		getchar();
		memset(map, 0, sizeof(map));
		ans = INF;
		for (int i = 0; i < h; i++)//建立地图。
		{
			int k = 0;
			for (int j = 0; j < 300; j++)
			{
				char temp = getchar();
				if ('0'<=temp&&temp<'9')
				{
					map[i][k] = temp;
					if (map[i][k] == '2')//记录起点
					{
						sx = i;
						sy = k;
					}
					else
					{
						if (map[i][k] == '3')//记录终点
						{
							gx = i;
							gy = k;
						}
					}
					k++;
				}
				else
				{
					if (temp == '\n')
					{
						break;
					}
				}
			}
		}
		map[sx][sy] = '0';//开始搜索之后,起点位置与空的位置没有区别,所以把起点置为0
		dfs(sx, sy, 0);
		if (ans == INF)
		{
			printf("-1\n");
		}
		else
		{
			printf("%d\n", ans);
		}
	}
	return 0;
}


posted @ 2018-04-12 17:04  focus5679  阅读(89)  评论(0编辑  收藏  举报