02-线性结构4 Pop Sequence

02-线性结构4 Pop Sequence(25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题解:

#include <iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<stack>
#include<cmath>
#include<cstring>
#define mod 1000000007
typedef long long ll;
using namespace std;
int a[1050];
int main()
{
    int m, n, k;
    scanf("%d%d%d", &m, &n ,&k);
    while(k--)
    {
        for(int i = 1;i < n+1; i++)
        {
            scanf("%d",&a[i]);
        }
        int cnt = 1, c = 1, q = 1;
        stack<int> sta;
        sta.push(0);
        sta.push(c);
        c++;
        cnt++;
        int flag = 1;
        while(sta.size() != 1 || c < n+1)
        {
            int temp = sta.top();
            if (sta.size()>m+1)
            {
                flag = 0;
                printf("NO\n");
                break;
            }
            if (temp == a[q])
            {
                sta.pop();
                cnt--;
                q++;
            }
            else
            {
                sta.push(c);
                cnt++;
                c++;
            }
        }
        if  (flag)
        {
            printf("YES\n");
        }
    }

    return 0;
}

posted @ 2018-05-01 14:43  focus5679  阅读(125)  评论(0编辑  收藏  举报