Big Number POJ - 1423

Big Number

 POJ - 1423 


In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
2
10
20
Sample Output
7
19

题解:

#include <queue>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n;
        scanf("%d", &n);
        double cnt= 0;
        for(int i = 2;i<=n;i++)
        {
            cnt += log10(i);
        }

        printf("%d\n", (int)cnt+1);
    }
    return 0;
}

posted @ 2018-05-13 13:14  focus5679  阅读(61)  评论(0编辑  收藏  举报