Prime Path POJ - 3126

Prime Path

 POJ - 3126 

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033 
1733 
3733 
3739 
3779 
8779 
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0

题解:

#include <set>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>

#define mod 1000000007
const int INF = 0x7f7f7f7f;
typedef long long ll;
const int maxn = 10050;
using namespace std;

int n, m;
bool vis[maxn];
struct node
{
	int x, step;
};


bool judge_prime(int x)
{
	if(x == 0 || x == 1)
		return false;
	else if(x == 2 || x == 3)
		return true;
	else
	{
		for(int i = 2; i <= (int)sqrt((double)x); i++)
			if(x % i == 0)
				return false;
		return true;
	}
}

void BFS(int a)
{
	int X, STEP, i;
	queue<node> que;
	vis[a] = true;
	node tmp;
	tmp.x = a;
	tmp.step = 0;
	que.push(tmp);
	while(!que.empty())
	{
		node tp;
		tp = que.front();
		que.pop();
		X = tp.x;
		STEP = tp.step;
		if(X == m)
		{
			printf("%d\n",STEP);
			return ;
		}
		for(i = 1; i <= 9; i += 2)
		{
			int s = X / 10 * 10 + i;
			if(s != X && !vis[s] && judge_prime(s))
			{
				vis[s] = 1;
				node temp;
				temp.x = s;
				temp.step = STEP + 1;
				que.push(temp);
			}
		}
		for(i = 0; i <= 9; i++)
		{
			int s = X / 100 * 100 + i * 10 + X % 10;
			if(s != X && !vis[s] && judge_prime(s))
			{
				vis[s] = 1;
				node temp;
				temp.x = s;
				temp.step = STEP + 1;
				que.push(temp);
			}
		}
		for(i = 0; i <= 9; i++)
		{
			int s = X / 1000 * 1000 + i * 100 + X % 100;
			if(s != X && !vis[s] && judge_prime(s))
			{
				vis[s] = 1;
				node temp;
				temp.x = s;
				temp.step = STEP + 1;
				que.push(temp);
			}
		}
		for(i = 1; i <= 9; i++)
		{
			int s = i * 1000 + X % 1000;
			if(s != X && !vis[s] && judge_prime(s))
			{
				vis[s] = 1;
				node temp;
				temp.x = s;
				temp.step = STEP + 1;
				que.push(temp);
			}
		}
	}
	printf("Impossible\n");
	return ;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(vis,0,sizeof(vis));
		BFS(n);
	}
	return 0;
}

posted @ 2018-05-19 16:17  focus5679  阅读(221)  评论(0编辑  收藏  举报