hdu1429 胜利大逃亡(续)(bfs+状态压缩)
胜利大逃亡(续)
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10777 Accepted Submission(s): 3911
Problem Description
Ignatius再次被魔王抓走了(搞不懂他咋这么讨魔王喜欢)……
这次魔王汲取了上次的教训,把Ignatius关在一个n*m的地牢里,并在地牢的某些地方安装了带锁的门,钥匙藏在地牢另外的某些地方。刚开始Ignatius被关在(sx,sy)的位置,离开地牢的门在(ex,ey)的位置。Ignatius每分钟只能从一个坐标走到相邻四个坐标中的其中一个。魔王每t分钟回地牢视察一次,若发现Ignatius不在原位置便把他拎回去。经过若干次的尝试,Ignatius已画出整个地牢的地图。现在请你帮他计算能否再次成功逃亡。只要在魔王下次视察之前走到出口就算离开地牢,如果魔王回来的时候刚好走到出口或还未到出口都算逃亡失败。
Input
每组测试数据的第一行有三个整数n,m,t(2<=n,m<=20,t>0)。接下来的n行m列为地牢的地图,其中包括:
. 代表路
* 代表墙
@ 代表Ignatius的起始位置
^ 代表地牢的出口
A-J 代表带锁的门,对应的钥匙分别为a-j
a-j 代表钥匙,对应的门分别为A-J
每组测试数据之间有一个空行。
Output
针对每组测试数据,如果可以成功逃亡,请输出需要多少分钟才能离开,如果不能则输出-1。
Sample Input
4 5 17 @A.B. a*.*. *..*^ c..b* 4 5 16 @A.B. a*.*. *..*^ c..b*
Sample Output
16 -1
Author
LL
Source
Recommend
linle
这题是我第一次接触状态压缩,感觉玄妙异常。
我们可以知道,一个人对一把钥匙的情况只有两种即持有和未持有,因此可以用0和1表示
因此想到二进制,每一位代表一把不同的钥匙得到一把钥匙可以将他现在的钥匙持有情况key和下一把钥匙(编号i)作'或'处理
key|(1<<i)
而能否打开门就可以用到'与'操作key&(1<<i),如返回0则无法开门,非零则可开门。
还有一点需要注意的是这样可能会走重复的路,因此标记改成了flag[x][y][key]同时对x,y,key的共同状态进行标记
代码:
#include<algorithm>
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
const int INF=0x3f3f3f3f;
struct node{
int x,y,depth;
int key;
node(int x=0,int y=0,int depth=0,int key=0):x(x),y(y),depth(depth),key(key){}
};
int sx,sy,n,mm;
int t;
int mve[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int flag[50][50][2000];
char m[50][50];
queue<node> q;
int check(node u)
{
char c=m[u.x][u.y];
if(u.x>=1&&u.x<=n&&u.y>=1&&u.y<=mm&&c!='*'&&!flag[u.x][u.y][u.key]) return 1;
return 0;
}
int bfs()
{
while(!q.empty()) q.pop();
node beg(sx,sy,0,0);
flag[sx][sy][0]=1;
q.push(beg);
while(!q.empty())
{
node fir=q.front();
q.pop();
if(fir.depth>=t) break;
for(int i=0;i<4;i++)
{
node nxt;
nxt.x=fir.x+mve[i][0];
nxt.y=fir.y+mve[i][1];
nxt.depth=fir.depth+1;
nxt.key=fir.key;
char c=m[nxt.x][nxt.y];
if(!check(nxt)) continue;
if(c>='a'&&c<='z')
{
nxt.key=(nxt.key|(1<<(c-'a')));
}
if(c>='A'&&c<='Z')
{
if((nxt.key&(1<<(c-'A')))!=((1<<(c-'A'))))
continue;
}
if(c=='^')
{
return nxt.depth;
}
q.push(nxt);
flag[nxt.x][nxt.y][nxt.key]=1;
}
}
return INF;
}
int main()
{
while(cin>>n>>mm>>t)
{
memset(flag,0,sizeof(flag));
int i;
for(i=1;i<=n;i++)
{
scanf("%s",m[i]+1);
}
for(i=1;i<=n;i++)
{
for(int j=1;j<=mm;j++)
{
if(m[i][j]=='@')
{
sx=i;
sy=j;
break;
}
}
}
int ans=bfs();
if(ans<t) cout<<ans<<endl;
else cout<<"-1"<<endl;
}
return 0;
}