Number Sequence HDU - 1711 (Hash或KMP)
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
Sample Output
6 -1
很简单的题目,是一道KMP的模板题,但也是Hash的模板题。
Hash代码:
#include<algorithm>
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#include <unordered_map>
#define endl '\n'
#define sc(x) scanf("%d",&x)
using namespace std;
typedef unsigned long long ULL;
const int size=1e6+5;
ULL H[size],P[size];
int s[size];
void Hash(int len,int PA=2333)
{
H[0]=0;
P[0]=1;
for(int i=1;i<=len;i++)
{
H[i]=H[i-1]*PA+s[i]+2000000;
P[i]=P[i-1]*PA;
}
}
ULL code(int l,int r)
{
return H[r]-H[l-1]*P[r-l+1];
}
unordered_map<ULL,bool> mp;
int main()
{
int t;
sc(t);
while(t--)
{
int n,m;
sc(n),sc(m);
for(int i=1;i<=n;i++) sc(s[i]);
Hash(n);
ULL s2=0;
int t;
for(int i=0;i<m;i++)
{
sc(t);
t+=2000000;
s2*=2333;
s2+=t;
}
int ans=0;
int i;
for(i=1;i+m-1<=n;i++)
{
if(code(i,i+m-1)==s2)
{
ans=1;
break;
}
}
if(ans) cout<<i<<endl;
else cout<<"-1"<<endl;
}
return 0;
}
KMP代码:
#include<algorithm>
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#define endl '\n'
#define sc(x) scanf("%d",&x)
using namespace std;
int nxt[10005];
int ss[1000005],s[10005];
int n,m;
void getnext()
{
nxt[0]=0,nxt[1]=0;
int j=0;
for(int i=1;i<m;i++)
{
j=nxt[i];
while(j&&s[i]!=s[j]) j=nxt[j];
if(s[i]==s[j]) nxt[i+1]=j+1;
else nxt[i+1]=0;
}
}
int query()
{
getnext();
int j=0;
int ans=0;
for(int i=0;i<n;i++)
{
while(j&&ss[i]!=s[j]) j=nxt[j];
if(s[j]==ss[i]) ++j;
if(j==m) return i-m+2;
}
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(nxt,0,sizeof(nxt));
sc(n),sc(m);
for(int i=0;i<n;i++) sc(ss[i]);
for(int i=0;i<m;i++) sc(s[i]);
int ans=query();
cout<<ans<<endl;
}
return 0;
}