POJ 3252 Round Number(数位DP)

Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6983   Accepted: 2384

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

题意
求二进制表示中0的个数大于1的数的个数。

分析
简单数位DP,用记忆化搜索
#include<iostream>
#include<cmath>
#include<cstring>
#include<queue>
#include<vector>
#include<cstdio>
#include<algorithm>
#include<map>
#include<set>

#define rep(i,e) for(int i=0;i<(e);i++)
#define rep1(i,e) for(int i=1;i<=(e);i++)
#define repx(i,x,e) for(int i=(x);i<=(e);i++)
#define X first
#define Y second
#define PB push_back
#define MP make_pair
#define mset(var,val) memset(var,val,sizeof(var))
#define scd(a) scanf("%d",&a)
#define scdd(a,b) scanf("%d%d",&a,&b)
#define scddd(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define pd(a) printf("%d\n",a)
#define scl(a) scanf("%lld",&a)
#define scll(a,b) scanf("%lld%lld",&a,&b)
#define sclll(a,b,c) scanf("%lld%lld%lld",&a,&b,&c)
#define IOS ios::sync_with_stdio(false);cin.tie(0)

using namespace std;
typedef long long ll;
template <class T>
void test(T a){cout<<a<<endl;}
template <class T,class T2>
void test(T a,T2 b){cout<<a<<" "<<b<<endl;}
template <class T,class T2,class T3>
void test(T a,T2 b,T3 c){cout<<a<<" "<<b<<" "<<c<<endl;}
const int N = 1e6+10;
//const int MAXN = 210;
const int inf = 0x3f3f3f3f;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const ll mod = 1000000007;
int T;
void testcase(){
    printf("Case #%d: ",++T);
}
const int MAXN = 1e5+5;
const int MAXM = 30;
int dp[50][50][50];
int bit[50];
//num0-0的个数
//num1-1的个数
//limit-边界标志
//z-前缀零标志
int dfs(int pos,int num0,int num1,bool limit,bool z){
    if(pos==-1) return num0>=num1;
    if(!limit&&dp[pos][num0][num1]!=-1) return dp[pos][num0][num1];
    int ed = limit?bit[pos]:1;
    int ans=0;
    for(int i=0;i<=ed;i++){
        //(z&&i==0)判断是否前面全为零
        ans += dfs(pos-1,(z&&i==0)?0:num0+(i==0),(z&&i==0)?0:num1+(i==1),limit&&i==ed,z&&i==0);
    }
    if(!limit) dp[pos][num0][num1]=ans;
    return ans;
}

int solve(int x){
    int xx=x;
    int tot=0;
    while(xx){
        bit[tot++]=xx&1;
        xx>>=1;
    }
    return dfs(tot-1,0,0,1,1);
}
int main() {
#ifdef LOCAL
    freopen("in.txt","r",stdin);
#endif // LOCAL

//    init();
    int l,r;
    scdd(l,r);
    mset(dp,-1);
    cout<<solve(r)-solve(l-1)<<endl;
    return 0;
}

 

 
 
posted @ 2018-04-30 14:53  litos  阅读(179)  评论(0编辑  收藏  举报