Minimum Transport Cost

Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

 

Sample Input
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

 

Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
题意:n个点的二维图,图中各点的代价给出,给出每个点作为中间点的代价。求任意两点之间的最短代价,并输出路径
题解:floyed算法+保存路径,用一个二维数组p[i][j]来保存路径。p[i][j]表示i的后继

#include<stdio.h>
#include<iostream>
#define inf 100000000
using namespace std;
int n;
int a[1005][1005];
int p[1005][1005];
int cost[1005];
void floyed()
{
 int i,j,k;
 for(i=1;i<=n;i++)
 {
  for(j=1;j<=n;j++)
  {
   p[i][j]=j;
  }
 }
 for(k=1;k<=n;k++)
 {
  for(i=1;i<=n;i++)
  {
   for(j=1;j<=n;j++)
   {
    int ans=a[i][k]+a[k][j]+cost[k];
    if(a[i][j]>ans)
    {
     a[i][j]=ans;
     p[i][j]=p[i][k];
    }
    else if(ans==a[i][j])
    {
     if(p[i][j]>p[i][k])
     {
      p[i][j]=p[i][k];
     }
    }
   }
  }
 }

}
int main()
{
     int i,j,c,d;
  while(scanf("%d",&n),n)
  {
   for(i=1;i<=n;i++)
   {
    for(j=1;j<=n;j++)
    {
     scanf("%d",&a[i][j]);
     if(a[i][j]==-1) a[i][j]=inf;
    }
   }
   for(i=1;i<=n;i++) scanf("%d",&cost[i]);
   floyed();
   while(scanf("%d %d",&c,&d))
   {
    if(c==-1&&d==-1) break;
    printf("From %d to %d :\n",c,d);
    printf("Path: %d",c);
    for(i=c;i!=d;i=p[i][d]) printf("-->%d",p[i][d]);
    printf("\n");
    printf("Total cost : %d\n\n",a[c][d]);
   }
  }
 return 0;
}

posted @ 2013-09-06 17:31  forevermemory  阅读(231)  评论(0编辑  收藏  举报