Prime Ring Problem

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
题意:给定一个数n求满足相邻元素的和值为素数的所有序列
题解:dfs

#include<stdio.h>
#include<math.h>
#include<string.h>
int n;
int arr[20];
int visit[20];
bool is(int n)
{
int i;
for(i=2;i<=(int)sqrt((double)(n));i++)
{
if(n%i==0) return false;
}
return true;
}
void dfs(int k)
{
int i;
if(k==n&&is(arr[1]+arr[n]))
{
for(i=1;i<n;i++)
{
printf("%d ",arr[i]);
}
printf("%d\n",arr[n]);
return;
}
for(i=2;i<=n;i++)
{
if(visit[i]==0&&is(arr[k]+i))
{
visit[i]=1;
arr[k+1]=i;
dfs(k+1);
visit[i]=0;
}
}
}
int main()
{
int i,ca=0;
while(scanf("%d",&n)!=EOF)
{
ca++;
printf("Case %d:\n",ca);
arr[1]=1;
memset(visit,0,sizeof(visit));
visit[1]=1;
dfs(1);
puts("");
}
return 0;
}

posted @ 2013-08-05 16:26  forevermemory  阅读(113)  评论(0编辑  收藏  举报