Visible Lattice Points

Description

A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, yN.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549
考察欧拉函数
#include<stdio.h>
#include<math.h>
int oula(int x)
{
 int temp=x,i;
 for(i=2;i<=(int)sqrt(x);i++)
 {
  if(x%i==0)
  {
   temp=temp/i*(i-1);
   while(x%i==0)  x/=i;
  }
 }
 if(x>1)  temp=temp/x*(x-1);
 return temp;
}
int main()
{
    int n,ca=0,sum,p,i,j;
 scanf("%d",&n);
 for(j=0;j<n;j++)
 {
       sum=0;
    ca++;
    scanf("%d",&p);
    for(i=2;i<=p;i++)
    {
     sum+=oula(i);
    }
       printf("%d %d %d\n",ca,p,sum*2+3);
 }
 return 0;
}

GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1841    Accepted Submission(s): 704 
Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest? No? Oh, you must do this when you want to become a "Big Cattle". Now you will find that this problem is so familiar: The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem: Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1. This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study. Good Luck!
 
Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 
Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.
 
Sample Input
2 4 0
 
Sample Output
0 1
#include<stdio.h>
#include<stdio.h>
int oula(int x)
{
 int i,temp=x;
 for(i=2;i<=(int)(x);i++)
 {
  if(x%i==0)
  {
   temp=temp/i*(i-1);
   while(x%i==0)  x/=i;
  }
 }
 if(x>1) temp=temp/x*(x-1);
 return temp;
}
int main()
{
     int n;
  while(scanf("%d",&n)&&n)
  {
   printf("%d\n",n-1-oula(n));
  }
 return 0;
}
posted @ 2013-05-01 19:31  forevermemory  阅读(253)  评论(0编辑  收藏  举报