Red and Black

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
char ss[30][30];
int m,n,X,Y;
bool flag[30][30];
struct lmx{
 int x;
 int y;
};
lmx lm[10000];
bool isarea(int x,int y)
{
 return (x>=0&&x<n&&y>=0&&y<m);
}
int c[4]={-1,0,1,0};
int d[4]={0,-1,0,1};
int  bfs()
{
 int head=0,rear=0,i,cnt=1;
 lmx l;
 l.x=X;
 l.y=Y;
 lm[rear++]=l;
 while(head<rear)
 {
  lmx q=lm[head];
  for(i=0;i<4;i++)
  {
  int xx=q.x+c[i];
  int yy=q.y+d[i];
  if(isarea(xx,yy)&&flag[xx][yy]==0&&ss[xx][yy]=='.')
  {
   lm[rear].x=xx;
   lm[rear].y=yy;
   flag[xx][yy]=1;
   rear++;
   cnt++;
  }
  }
  head++;
 }
  return cnt;
}
int main()
{
int i,j;
while(cin>>m>>n&&m+n)
{
 memset(flag,0,sizeof(flag));
 for(i=0;i<n;i++)
 {
  for(j=0;j<m;j++)
  {
   cin>>ss[i][j];
   if(ss[i][j]=='#')  flag[i][j]=1;
   if(ss[i][j]=='@')  {X=i;Y=j;flag[i][j]=1;}
  }
 }
    cout<<bfs()<<endl;
}
 return 0;
}
posted @ 2013-03-07 19:59  forevermemory  阅读(168)  评论(0编辑  收藏  举报