Power Strings

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
#include<iostream>  
#include<cstdlib>  
#include<stdio.h>  
#include<string.h>  
using namespace std; 
const int maxm = 1000010;     // 模式串的最大长度  
char p[maxm]; 
int  m, next[maxm]; 
void getNext() 

        int i = 0, j = next[0] = -1; 
        while(i < m) 
        { 
            if (j == -1 || p[i] == p[j]) 
            { 
 
                ++i; ++j; 
                next[i] =j; 
 
            } 
            else 
            j = next[j]; 
        } 
 

 
int main() 

       while(scanf("%s",p)!=EOF) 
       { 
           if(p[0]=='.') break; 
           m=strlen(p); 
           getNext(); 
           int cc=1; 
           if(m%(m-next[m])==0) 
           cc=m/(m-next[m]); 
           cout<<cc<<endl; 
       } 
posted @ 2013-03-04 15:56  forevermemory  阅读(140)  评论(0编辑  收藏  举报