SUBSTRING

Problem Description

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input.
Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

Input

The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').

Output

Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input

Sample Input

3                   
ABCABA
XYZ
XCVCX

Sample Output

ABA
X
XCVCX

注意:题目意思不是求最长连续可逆字符串

#include<iostream>
#include<string>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
 int n,i,j,flag;
  string s1,ss;
    cin>>n;
 string s;
 while(n--)
 {
  cin>>s;
  flag=0;
  for(i=s.length();i>0;i--)
  {
   for(j=0;j+i<=s.length();j++)
   {
      
                 ss=s.substr(j,i);
     s1=ss;
                 reverse(s1.begin(),s1.end());
     if(s.find(s1)!=-1)  {cout<<ss<<endl;flag=1;break;}
   }
   if(flag==1)  break;
  }
 }

 return 0;
}

posted @ 2012-12-13 22:43  forevermemory  阅读(166)  评论(0编辑  收藏  举报