Strange fuction

Problem Description

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

 

#include<iostream>
using namespace std;
double lmx(double x,double y)
{
 return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x;
}
double y;
double fan(double head,double rear)
{
 double mid1,mid2;
 while(rear-head>1.0e-6)
 {
  mid1=(2*head+rear)/3;
  mid2=(head+2*rear)/3;
  if(lmx(mid1,y)<lmx(mid2,y))
  {
   rear=mid2;
  }
  else head=mid1;
 }
 return lmx(mid1,y);
}
int main()
{
int t,i;
cout.precision(4);
cin>>t;
while(t--)
{
 cin>>y;
 cout<<fixed<<fan(0,100)<<endl;
}
 return 0;
}

posted @ 2012-12-02 22:32  forevermemory  阅读(109)  评论(0编辑  收藏  举报