深度优先搜索篇Tempter of the Bone

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40933    Accepted Submission(s): 11070


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
NO YES

 

#include<iostream>
using namespace std;
char p[8][8];
int biaoji;
int c[4]={0,1,0,-1};
int d[4]={-1,0,1,0};
int x1,y1,x2,y2,m,n,T;
int lmx(int x)
{
 if(x>=0)  return x;
 else return -x;
}
void dfs(int x,int y,int t)
{
 int i,xx,yy;
   if(t==T&&x==x2&&y==y2)
   {
        biaoji=1;
   }
   if(biaoji==1)  return;//此语句与上面一句必须分开否则超时暂时没想明白
   if((lmx(x2-x)+lmx(y2-y))%2!=(T-t)%2||t>T) return;//重要的奇偶剪枝剩余的时间和剩下的步数就行必须相同
   for(i=0;i<4;i++)
   {
         xx=x+c[i];
   yy=y+d[i];
   if(p[xx][yy]!='X'&&xx>=0&&xx<m&&yy>=0&&y<n)
   {
    p[xx][yy]='X';
    dfs(xx,yy,t+1);
    p[xx][yy]='.';
   }
   }
}
int main()
{
int i,j,cnt;
while(cin>>m>>n>>T)
{
 if(m==0&&n==0&&T==0)  break;
 cnt=0;
 for(i=0;i<m;i++)
 {
  for(j=0;j<n;j++)
  {
   cin>>p[i][j];
   if(p[i][j]=='S')  {x1=i;y1=j;}
   if(p[i][j]=='D')  {x2=i;y2=j;cnt++;}
   if(p[i][j]=='.') cnt++;
  }
 }
 if(cnt<T||lmx(x2-x1)+lmx(y2-y1)>T) cout<<"NO"<<endl;//剪枝判断是否有搜索的必要加上此句快乐三百多ms
 else
 {
  p[x1][y1]='X';
  biaoji=0;
  dfs(x1,y1,0);
  if(biaoji==1)  cout<<"YES"<<endl;
  else cout<<"NO"<<endl;
    }
}
 return 0;
}

posted @ 2012-10-28 20:53  forevermemory  阅读(194)  评论(0编辑  收藏  举报