题目链接:
http://poj.org/problem?id=2960
S-Nim
Time Limit: 2000MS
Memory Limit: 65536K
#### 问题描述
> Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
> The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
> The players take turns chosing a heap and removing a positive number of beads from it.
> The first player not able to make a move, loses.
> Arthur and Caroll really enjoyed playing this simple game until they
> recently learned an easy way to always be able to find the best move:
> Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
> If the xor-sum is 0, too bad, you will lose.
> Otherwise, move such that the xor-sum becomes 0. This is always possible.
> It is quite easy to convince oneself that this works. Consider these facts:
> The player that takes the last bead wins.
> After the winning player's last move the xor-sum will be 0.
> The xor-sum will change after every move.
> Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.
>
> Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S = {2, 5} each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
>
> your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
输入
Input consists of a number of test cases.
For each test case: The first line contains a number k (0 < k ≤ 100) describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps.
The last test case is followed by a 0 on a line of its own.
输出
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'.
Print a newline after each test case.
样例
sample input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
sample output
LWW
WWL
题意
题目是对石子问题的改遍,限制了取石子的个数。
题解
由于数据比较小,我们暴力求出一堆的情况下的SG值,然后每一堆的SG值异或一下就是答案。
代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=111;
const int maxm = 10101;
int st[maxn],sg[maxm];
int vis[maxm];
int n, m;
void get_sg() {
sort(st, st + n);
for (int i = 0; i < st[0]; i++) {
sg[i] = 0;
}
for (int i = st[0]; i < maxm; i++) {
memset(vis, 0, sizeof(vis));
for (int j = 0; j < n; j++) {
if (i - st[j] >= 0) {
vis[sg[i - st[j]]] = 1;
}
}
for (int j = 0;; j++) if (!vis[j]) {
sg[i] = j; break;
}
}
}
int main() {
while (scanf("%d", &n) == 1 && n) {
for (int i = 0; i < n; i++) scanf("%d", &st[i]);
get_sg();
scanf("%d", &m);
string ans;
while (m--) {
int sum = 0;
int cnt; scanf("%d", &cnt);
for (int i = 0; i < cnt; i++) {
int x; scanf("%d", &x);
sum ^= sg[x];
}
if (sum == 0) ans += 'L';
else ans += 'W';
}
printf("%s\n", ans.c_str());
}
return 0;
}