A - Biorhythms (第三周)

A - Biorhythms

 

链接:https://vjudge.net/contest/154063#problem

Description 人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。 
Input 输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。 

当p = e = i = d = -1时,输入数据结束。 
 
 
 
Output
    从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。 

采用以下格式: 
Case 1: the next triple peak occurs in 1234 days. 

注意:即使结果是1天,也使用复数形式“days”。 
 
 

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.
通过例子说明这道题的大意
以 第三个样例 5 20 34 325 为例,p,e,i 三个高峰分别出现在距当年开端的第5天,第20天,第34天,date是距当年开端的第325天。要求date离下一个三重高峰的天数(不算入date)。注意 5,20, 34并不一定是当年p,e,i各自第一个高峰出现的时间,由题意,p,e,i的周期长度分别为23, 28, and 33,故此此例中三个曲线在当年第一次出现高峰的日期分别是5,20和1(34-33)。
 
 
可以应用中国剩余定理。我是直接暴力求解。
 
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdlib>
using namespace std;
int main()
{
    int p,e,i,d,n=0;
    while(scanf("%d%d%d%d",&p,&e,&i,&d)!=EOF)
    {
        n++;
        if(p<0)  break;
        for(int j=d+1; j<30000; j++)
        {
            if((j-d)>21252)
            {
                printf("Case %d: the next triple peak occurs in 21252 days.\n",n);
                break;
            }
            if(abs(j-p)%23!=0) continue;
            if(abs(j-e)%28!=0) continue;
            if(abs(j-i)%33!=0) continue;
            printf("Case %d: the next triple peak occurs in %d days.\n",n,j-d);
            break;
        }
    }
    return 0;
}

剩余定理解法链接:http://blog.sina.com.cn/s/blog_9cf9f2550101f0ek.html

posted @ 2017-03-18 15:21  枫虹  阅读(270)  评论(0编辑  收藏  举报