Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 112071 Accepted Submission(s): 43735
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
题意:多组数据,先输入一个N (0 < N <= 1000),代表有这么多个气球颜色,当N为零的时候输入结束,输出出现次数最多的气球颜色;
我的思路:用一个二维数组保存气球的颜色,同时用个一维数组充当计数器,当输入一组数据,偏遍历前面的数据与之比较,相同计数器加一即可;
AC代码:
#include <stdio.h>
#include <stdio.h>
int num[1005];
char colour[1005][16];
int main (){
int n,i,j;
while (scanf("%d",&n),n){
num[0]=1;
scanf("%s",colour[0]);
for (i=1;i<n;i++){
num[i]=1;
scanf("%s",colour[i]);
for (j=0;j<=i-1;j++){
if (strcmp(colour[i],colour[j])==0){
num[j]++;
}
}
}
int max=0,count;
for (i=0;i<n;i++)
if(max<num[i]){
max=num[i];
count=i;
}
printf("%s\n",colour[count]);
}
return 0;
}
博主开始刷英文题了