Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 56132 Accepted Submission(s): 26291
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word “yes” if 3 divide evenly into F(n).
Print the word “no” if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no
写过类似的题目,找规律,列出前十几个数,发现出现循环规律,第二项,第六项,第十项均是3的倍数,即4个一组循环,下面就很简单了
AC代码:
#include <stdio.h>
int main(){
long n;
while(scanf("%ld",&n)!=EOF){
if(n==0||n==1)
printf("no\n");
else if((n-2)%4==0)
printf("yes\n");
else
printf("no\n");
}
return 0;
}