Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26069 Accepted Submission(s): 10505

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output
0
2C
11
-2C
-90

AC代码:

#include <stdio.h>
#include <string.h>
int main (){
    long long int a,b;
    while (scanf("%llX%llX",&a,&b)!=EOF){
        if (a+b < 0) printf("-%llX\n",-(a+b));
        else printf("%llX\n",a+b);      
    }   
    return 0;
} 

只要注意%x十六位无符号型,且注意题目中的数据范围,使用lld