POJ 1001

POJ 1001

 

Exponentiation

Time Limit: 500MS   Memory Limit: 10000K
Total Submissions: 180243   Accepted: 43444

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

用了JAVA的bigDecimal

package TEST;
import java.util.*;
import java.io.*;
import java.lang.String;
import java.math.BigDecimal;
 
public class Main
{
    public static void main(String[] args)
    {
        String s1;
        int n;
        Scanner cin = new Scanner(System.in);        
        s1 = cin.next();
        n = cin.nextInt();
        BigDecimal b1 = new BigDecimal(s1);
        BigDecimal b2 = b1.pow(n);
        System.out.println(b2);
        cin.close();
    }
}

Eclipse运行正确,但是OJ运行是错的。。。

没有考虑while(cin)的情况以及 要去除多余的0

可用stripTrailingZeros()函数 

import java.util.*;
import java.io.*;
import java.lang.String;
import java.math.BigDecimal;
 
public class Main
{
    public static void main(String[] args)
    {
        BigDecimal b1, b2;
        int n=0;
        Scanner cin = new Scanner(System.in);        
        while(cin.hasNext())
        {
        b1=cin.nextBigDecimal();
        n=cin.nextInt();
        b2 = b1.pow(n);
        String s=b2.stripTrailingZeros().toPlainString();//把数字转化为字符串
        if(s.startsWith("0."))
            s=s.substring(1);//根据题目要求,如果是大于0小于1的数字要把前边的0去掉
        System.out.println(s);
        }
    }
}

值得注意的是:POJ默认的类是Main 

posted @ 2018-07-18 09:46  fantastic123  阅读(144)  评论(0编辑  收藏  举报