EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::
Wooden Sticks
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 14948   Accepted: 6133

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

Source

 

 

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

typedef struct
{
    int l;
    int w;
}STICK;

int t,n;
STICK stick[5010];
int rlt;
int dp[5010];

bool cmp(STICK s1, STICK s2)
{
    bool flag=false;

    if(s1.l<s2.l)
    {
        flag=true;
    }
    else if(s1.l==s2.l)
    {
        if(s1.w<s2.w)
        {
            flag=true;
        }
    }

    return flag;
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d %d",&stick[i].l,&stick[i].w);
        }

        sort(stick,stick+n,cmp);

        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=1; i<n; i++)
        {
            int max=1;
            for(int j=0; j<=i; j++)
            {
                if(stick[i].w<stick[j].w && dp[j]+1>max)
                {
                    max=dp[j]+1;
                }
                dp[i]=max;
            }
        }
        rlt=-1;
        for(int i=0; i<n; i++)
        {
            if(rlt<dp[i])
            {
                rlt=dp[i];
            }
        }
        printf("%d\n",rlt);

    }
    return 0;
}
posted on 2012-08-19 22:39  Eric-Yang  阅读(249)  评论(0编辑  收藏  举报