EricYang

Tech Spot of Eric

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::
Heavy Transportation
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 14202   Accepted: 3748

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany
 
dijkstra变形:  d[v]=max(d[v],min(d[u],map[u][v]));
 
Source Code

Problem: 1797		User: BUPT_ERIC
Memory: 4164K		Time: 438MS
Language: C++		Result: Accepted
Source Code
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int n,m;
int map[1010][1010];
int d[1010];
bool isUsed[1010];

void dijstra()
{
    int i,j;
    int maxVal,maxNode;
    int minVal;

    for(i=1; i<=n; i++)
    {
        d[i]=map[1][i];
    }
    isUsed[1]=true;
    for(i=1; i<=n-1 ;i++)
    {
        maxVal=-1;
        maxNode=1;
        for(j=1; j<=n; j++)
        {
            if(!isUsed[j] && d[j]>maxVal)
            {
                maxVal=d[j];
                maxNode=j;
            }
        }
        isUsed[maxNode]=true;
        for(j=1; j<=n; j++)
        {
            if(!isUsed[j])
            {
                minVal=map[maxNode][j]<d[maxNode]?map[maxNode][j]:d[maxNode];
                if(minVal>d[j])
                {
                    d[j]=minVal;
                }
            }
        }
    }
    printf("%d\n\n",d[n]);

}

int main()
{
    int casNum;
    int cros1,cros2,weight;
    scanf("%d",&casNum);

    for(int cas=1; cas<=casNum; cas++)
    {
        printf("Scenario #%d:\n",cas);
        memset(isUsed,0,sizeof(isUsed));
        memset(map,0,sizeof(map));
        scanf("%d %d",&n,&m);
        for(int i=1; i<=m ;i++)
        {
            scanf("%d %d %d",&cros1,&cros2,&weight);
            map[cros1][cros2]=weight;
            map[cros2][cros1]=weight;
        }
        dijstra();
    }
    return 0;
}

  

posted on 2012-05-02 23:17  Eric-Yang  阅读(294)  评论(0编辑  收藏  举报